Installation

Install Python 3.7 or later, if you dont already have it.

Install Locust:

$ pip3 install locust

Validate your installation:

$ locust -V
locust 2.10.1

Now it is time to create your first test!

Note

If you have any issues installing, check the wiki for possible solutions.

Pre-release builds

If you need the latest and greatest version of Locust and cannot wait for the next proper release, you can install a dev build like this:

$ pip3 install -U --pre locust

Pre-release builds are published every time a branch/PR is merged into master.

Install for development

If you want to modify Locust, or contribute to the project, see Developing Locust.